• Register

Javljanje napake (deprecated since SymPy 1.5)

+1 vote
73 views
C:\ProgramData\Anaconda3\lib\site-packages\sympy\core\relational.py:470: SymPyDeprecationWarning: 

Eq(expr) with rhs default to 0 has been deprecated since SymPy 1.5.
Use Eq(expr, 0) instead. See
https://github.com/sympy/sympy/issues/16587 for more info.

  deprecated_since_version="1.5"
 
Mogoče še kdo s takim sporočilom? To je pri zadnji domači nalogi, vprašanje številka 11.
 
Hvala
asked Apr 10 by andrejgregoric (400 points)

1 Answer

+1 vote
 
Best answer
Nova verzija knjižnice več tega ne podpira oziroma ne bo več podpirala.

Predvidevam, da je tvoja koda neki takega:

enacba = sym.Eq(polinom)

Zapiši raje:

enacba = sym.Eq(polinom, 0)

Zdej imaš definirani obe strani enačbe in nebi smelo javljat napake.
answered Apr 10 by giannidaris (570 points)
selected Apr 10 by janko.slavic
Deluje. Odlično, hvala!
...